+ Reply to Thread
Results 1 to 4 of 4

Thread: How to remove www. prefix from the site main URL ?

  1. #1
    Junior Member
    Join Date
    Jun 2017
    Posts
    25

    How to remove www. prefix from the site main URL ?

    Hello, I was looking for correct information on all the places I need to touch to configure FlyNax to work without the www. prefix in the URL

    for example, I want the default site to be https://concreteiron.com and NOT https://www.concreteiron.com

    On a normal static website, I would just put some redirects in .htaccess to catch any other flavors of urls entered.
    However with all the URL rewriting and CMS things going on here, I was looking for a clear technical answer of all the places that this config needs to be changed?

    1. I assume some more rewrite statements in .htaccess, but exactly what? and where in .htaccess should it be? before what statement? after what statement?
    Can someone provide the exact rewrite statement to use here? or which one to remove / modify?

    2. I would also assume that /includes/config,inc.php would need to be modified on system URLS

    // system URLs
    define( 'RL_URL_HOME', 'https://www.concreteiron.com/' );

    Changed To
    // system URLs
    define( 'RL_URL_HOME', 'https://concreteiron.com/' );

    3. What other things need to be changed in config to have it operate on just https://concreteiron.com as the base URL?

  2. #2
    Hello Tim,

    Open file: ftp://includes>>config.inc.php

    find line: define('RL_URL_HOME', 'https://www.concreteiron.com/'); and remove 'www.'
    You don't need to change anything more.
    Viktor,
    Flynax technical department,
    Best wishes.

  3. #3
    Member
    Join Date
    Jan 2019
    Location
    uk
    Posts
    44
    hi ive done that now I get too many redirects when I click on any categories need help

  4. #4
    Flynax developer Rudi's Avatar
    Join Date
    Dec 2014
    Location
    Planet Earth
    Posts
    2,082
    Probably, the ssl certificate is configured for www on your server

    you should check it

    or create a ticket for the issue

+ Reply to Thread