+ Reply to Thread
Results 1 to 4 of 4

Thread: Multifield/Location Filter - 2nd level not working

  1. #1

    Multifield/Location Filter - 2nd level not working

    Good day all together!

    I have an issue with the multifield/location filter:
    When choosing a country/state (1st level), the filter works fine.
    When choosing a region (2nd level), the filter sometimes produces errors, depending on the region or language chosen.
    For example... a region chosen in german delivers an error, while the same region chosen in english is working.

    Does anyone have an idea, what could be the reason for this?

    1st_level-working.jpg
    2nd_level_working.jpg
    2nd_level_error.jpg

    Thanks in advance!

  2. #2
    Flynax developer Rudi's Avatar
    Join Date
    Dec 2014
    Location
    Planet Earth
    Posts
    2,176
    Hello,

    You'd better create a ticket as this issue is related to Category Filter plugin

  3. #3
    Hi Rudi,

    meanwhile, i translated some of the regions back to their "original" title (as per world locations database) - and voila' the filter works again.
    So it seems to be definetely a language issue. As soon as a State/Province is given another name - you get an error.

    The only problem... in the database, some of the States have a wrong German title and when you correct it, the filter runs into confusion.

  4. #4
    Is there a simple way to have the filter building the respective 2nd level link from the english title only?

    for example
    mydomain.com/serviceads/country:?sterreich/country-level1:Styria/
    instead of
    mydomain.com/serviceads/country:?sterreich/country-level1:Steiermark/

+ Reply to Thread