+ Reply to Thread
Results 1 to 2 of 2

Thread: Photos Upload from XML Feed with "cron_photos.php" File

  1. #1

    Photos Upload from XML Feed with "cron_photos.php" File

    Hello Dear Flynax team,

    Let me start from "Listing Packages".
    I have setting up package for "Unlimited pictures".

    Now i am trying to Export data from XML,
    I have mapped some values in mapping manager, like "Photos", "Price", "System XML Feed ID", Etc...

    Now i run my XML Feed with ONE listing to test it with this settings:
    File reading method -> " Copy the file and proceed to importing (default)",
    Delayed photo import -> "No",
    Update photos when updating listings -> "No",
    HTTP authorization -> "No",
    Import only new ads -> "No"


    Listing was added, photos - no.

    Trying with terminal:
    php -f /{path_to_web}/plugins/xmlFeeds/cron_photos.php > /path_to_log}/cron_photos.log
    Nothing happening. Log are clear

    Changing settings,
    As we know "import.php" file launch import of all feeds entirely
    "cron_photos.php" file imports only photos which was delayed for import via admin panel: your feed > Edit > Delayed photo import

    Setting Up feed:
    Delayed photo import -> "Yes",
    Number of photos to be imported in this session -> "0" #Number of photos of a particular ad; the others will be imported later. Leave the field empty or enter 0 to delay all photos.


    Trying to upload photos with "cron_photos.php" file, from terminal.
    php -f /{path_to_web}/plugins/xmlFeeds/cron_photos.php > /path_to_log}/cron_photos.log
    Nothing happening. Log are clear

    Result - pictures was not upload.

    Format in my XML File is :
    <vehicle>
    <make>
    <model>
    <etc...>
    <images>
    <image>
    <image>
    <...>
    </images>
    </vehicle>


    Now look at Database;
    Finding my ad.
    Table : {prefix}_listings -> Filed: Main_photo - Empty
    Table : {prefix}_listings -> Filed: Main_photo_x2 - Empty
    Table : {prefix}_listings -> Filed: Photos_count - "0"
    Table : {prefix}_listing_photos -> Filed: Listing_ID - #No my Listing ID here

    Looking at FTP;
    /{path_to_web}/files/12-2019/{ad ID}
    Folder is contains my photos, but in Database i cant see paths.

    Trying to delete folder with photos and rerun "cron_photos" script.
    [I]Delayed photo import -> "Yes"
    php -f /{path_to_web}/plugins/xmlFeeds/cron_photos.php
    Nothing happening.

    What Can i do ?

    For example another feed with same settings works. (without "cron_photos.php" file)


    Regards,
    Alex
    Last edited by Alex U; December 17, 2019 at 12:30 PM.

  2. #2
    Flynax developer Rudi's Avatar
    Join Date
    Dec 2014
    Location
    Planet Earth
    Posts
    2,017
    Hello Alex,

    Could you create a ticket to keep discussion directly there ?

    because I need to look into the issue and check your xml feed and all the plugin settings

    it's a broad topic


    Thanks

+ Reply to Thread