+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: All Categories Missing After Deleting One SubCategory

  1. #1

    All Categories Missing After Deleting One SubCategory

    I deleted the "spiders" subcategory and now ALL my categories disappeared. If you go to browse/view them in the admin, they say none exist. And, if you try to view them in the front end, it shows none exist. If you try to add a new listing, the user has none to choose from. And, when I deleted the spider category, it said "are you sure you want to delete the "spider" category. So I know I didn't accidentally delete any root categories. However, if you go to edit them, it shows them all there except the spider that I deleted. That's the only thing keeping me from having a heart attack. How can I fix plz? Until this fixed, nothing else I can do for my program :cry: Note: some of these titles were renamed by me but I would hope it's not affecting the code.

    Edit: I just noticed if you look in picture two, that all the subcategories lost their parent category. Sure, I could add everyone manually, but it will take a long time and will it happen again? Please help!

    [attachment=0:4g6zffuv]categories_missing.png[/attachment:4g6zffuv]

  2. #2
    Flynax developer
    Join Date
    Sep 2009
    Posts
    638

    Re: All Categories Missing After Deleting One SubCategory

    Hello again,

    Very strange issue.. actually first time i see this problem.. so only action in Admin Panel you made is delete one child category?

    Please PM me admin panel access i will try to help.

  3. #3

    Re: All Categories Missing After Deleting One SubCategory

    Yes, only deleted one subcategory and all parents are gone now. Thanks Mike F - Just PM'd you my details

  4. #4

    Re: All Categories Missing After Deleting One SubCategory

    Still waiting for someone to take a look at this so I can go live! This problem prevents me from doing anything until resolved! :roll:

  5. #5

    Re: All Categories Missing After Deleting One SubCategory

    Sweet, Mike fixed my problem! Thanks so much Mike! For some reason all the parent categories were missing in the database. Scary, but everything restored now thanks to Mike!

  6. #6
    Flynax developer John's Avatar
    Join Date
    Oct 2009
    Posts
    575

    Re: All Categories Missing After Deleting One SubCategory

    Hello Christina,
    Glad to hear that your problem was fixed, we will review this issue in the next software version.
    Thanks for assistance.

  7. #7
    Junior Member
    Join Date
    Apr 2010
    Posts
    11

    Re: All Categories Missing After Deleting One SubCategory

    The Same problem happen to me also today, i already sent my details to mike id please rectify this issue soon

  8. #8
    Junior Member
    Join Date
    Apr 2010
    Posts
    11

    Re: All Categories Missing After Deleting One SubCategory

    In my case after submitting few child category's, actually it correctly displayed in front end but in admin "category/browse" i found 2 duplicate child category so i delete one child entry, after that only i came to know that all category are not there.

    Actually i only delete child category !

  9. #9
    Flynax developer John's Avatar
    Join Date
    Oct 2009
    Posts
    575

    Re: All Categories Missing After Deleting One SubCategory

    Hi there,
    Dear Manikandan Subramanian, could you PM me your server FTP and phpmyadmin access details please, I will try to solve your issue.

    John

  10. #10
    Junior Member
    Join Date
    Apr 2010
    Posts
    11

    Re: All Categories Missing After Deleting One SubCategory

    the problem has been fixed immediately thanks to linda

    enough stuff flynax team has

+ Reply to Thread