Results 1 to 7 of 7

Thread: Wildcard subdomian - page not found problem

Threaded View

  1. #1

    SOLVED Wildcard subdomian - page not found problem

    Trying to set up Wildcard subdomain

    1) Hosting /w Linode
    DNS Manager
    Hostname IP Address
    added "A" record
    *.Domain IP num

    2) Using VestaCP using apache 2.215 only ( no nginx frontend)
    DNS Zone file
    * 14400 IN A Domain IP

    3) Server Alias in apache configuration file
    <VirtualHost *:80>
    DocumentRoot /home/www/
    ServerAlias *.domain. com

    Restarted Apache

    4) Flynax Admin
    Geo Filter - Location on subdomains = enable

    However when I click on Country getting: ERROR 404: Requested page not found.

    Am I missing anything here?

    Forgot to mention before Flynax install /w (1) to (3) above wildcard was working i.e.
    all of the above was working - no errors

    I forgot, VestaCP also requires a CNAME record ...Arrr stupid me
    After Adding it , rebooting server and clearing Flynax cache
    It worked !
    Last edited by Nizam Karim; July 9, 2017 at 06:39 PM. Reason: solution