+ Reply to Thread
Results 1 to 7 of 7

Thread: Wildcard subdomian - page not found problem

  1. #1

    SOLVED Wildcard subdomian - page not found problem

    Trying to set up Wildcard subdomain

    1) Hosting /w Linode
    DNS Manager
    Hostname IP Address
    added "A" record
    *.Domain IP num

    2) Using VestaCP using apache 2.215 only ( no nginx frontend)
    DNS Zone file
    * 14400 IN A Domain IP

    3) Server Alias in apache configuration file
    <VirtualHost *:80>
    DocumentRoot /home/www/domain.com/public_html
    ServerName domain.com
    ServerAlias *.domain. com

    Restarted Apache

    4) Flynax Admin
    Geo Filter - Location on subdomains = enable

    However when I click on Country getting: ERROR 404: Requested page not found.

    Am I missing anything here?

    Forgot to mention before Flynax install /w (1) to (3) above wildcard was working i.e.
    all of the above was working - no errors

    I forgot, VestaCP also requires a CNAME record ...Arrr stupid me
    After Adding it , rebooting server and clearing Flynax cache
    It worked !
    Last edited by Nizam Karim; July 9, 2017 at 06:39 PM. Reason: solution

  2. #2
    I did all the above and failed to make it work it on Cent os7 Cpanel, is there any special setting that need to be addressed to on CentOS7?

  3. #3
    Hello Sam,

    If you use Cpanel you need to create wildcard domain only and all subdomains will work.
    Flynax technical department,
    Best wishes.

  4. #4
    Dear Viktor

    I Created wildcard domain successfully, Then changed Listing_type setting in admin, restarted apache

    Tried after an hour - Did not work

    Then created record in Zone Editor pointing to same IP, restarted apache

    still did not work

  5. #5
    I am still facing problem, Have created a ticket also, Please help

  6. #6
    Wildcard domain has worked, it was because of Auto SSL was not providing SSL certificate for subdomains.

    Somehow when Subdomain is switched on from FlynaxAdminPanel - buyers can not send message to sellers and message sending screen is stuck at loading

    now I have given up on wildcard and have moved on,Snip20180718_4.png

  7. #7
    I have checked it on your side and all working properly for me. I have answered you in ticket and send video too.
    Flynax technical department,
    Best wishes.

+ Reply to Thread