+ Reply to Thread
Results 1 to 10 of 10

Thread: CKeditor

  1. #1

    Angry CKeditor

    Ckeditor is changeing the follow code


    http://prntscr.com/gt9jdq

    had to make a screenshot this editor here dont like the code either
    Last edited by Mustafa ilker Yonel; October 4, 2017 at 05:23 PM. Reason: ckeditor garbage

  2. #2
    Master
    Join Date
    Apr 2017
    Location
    Tehran/Iran
    Posts
    463
    1: </i> where is <i> at the beginning?
    2:<span class=...>where is your text here?</span>
    3:<i class...>where is your text here?</i>

    Poor ckeditor!

  3. #3
    ok some typos because i was angry! anywhere i try to post code at flynax nothing accept it ? thats poor.. when i use the
    Code:
    Only registered members can view the code.
    u are indeed a poor editor. my guess it has settings for it anywhere. but flynex should set the settings right

  4. #4
    Hello Mustafa,

    CKEditor it is 3rd party text editor. What is your suggestion for it?

    Also I don't understand why do you use [ PHP ] tags for insert html code.
    Before insert html code click on Source button and put your code: https://screencast.com/t/HnhwKsw7j
    without any php tags.
    Viktor,
    Flynax technical department,
    Best wishes.

  5. #5
    victor thanks for your answer

    of course i use the source code button

    try the code similar to this screenshot

    http://prntscr.com/guhh3s

    you will see that ckeditor removes empty tags ... last time i used this editor was 10 years ago i tryd to look up the settings i try to remember how to deactivate this nonsense. didnt found it yet and no time to investigate that much.

  6. #6
    Hello Mustafa,

    Try to change 1 config.
    Open file: ftp://libs>>ckeditor>>config.js

    find
    Code:
    Only registered members can view the code.
    replace to:
    Code:
    Only registered members can view the code.
    save and try to use your code again.
    Viktor,
    Flynax technical department,
    Best wishes.

  7. #7
    i did try that not working

    still deleting empty tags

    Code:
    Only registered members can view the code.
    after saving it changes to :
    Code:
    Only registered members can view the code.

  8. #8
    Hello Mustafa,

    I found easy solution for your code. Add space into your empty code.
    Code:
    Only registered members can view the code.
    Viktor,
    Flynax technical department,
    Best wishes.

  9. #9
    Master
    Join Date
    Apr 2017
    Location
    Tehran/Iran
    Posts
    463
    You should use commands like below for each tag
    Code:
    Only registered members can view the code.
    full list for ckeditor 4 is here.
    https://docs.ckeditor.com/ckeditor4/...-S-removeEmpty

    I am not sure, if it works for version 3

  10. #10
    Thanks Victor,

    Your solution is a easy fix, why i didnt test that myself ?! sometime you cant find the solutions in front of you

    thanks again.

+ Reply to Thread