+ Reply to Thread
Results 1 to 7 of 7

Thread: [Plugin} Social Meta tag img fetch

  1. #1

    Angry [Plugin} Social Meta tag img fetch

    Hi,

    The site is http://services.bg/

    I am testing the Social Meta tag and there is something weird.
    Facebook is not fetching image.

    but .. http://smo.knowem.com/ is showing and fetching image.

    When you open site info it shows OG tags and image path.
    When you type image path into browser, it gives 404.

    I have not edited .htaccess. They are as by install default.
    So where could be the problem?
    I see in .htaccess everthing is redirected to index.php
    Tried to disable those redirects, but still no go!?

  2. #2
    While inner pages like category page http://services.bg/uslugi/domashni-u...-services.html
    Are fetching default logo image correctly.
    I think the plugin has a bug.

  3. #3
    Hello Stefan,


    At first, i advise to check meta tags by open graph tool: https://developers.facebook.com/tools/debug/og/object/


    It shows now that your website doesn't have 2 required fields: FB:Admins and FB:App_id.
    You need fill it correctly and after try to fetch info again.

    Attached Images Attached Images
    Thank you, Curtis.
    @Flynax Company

  4. #4
    Thanks Curtis,

    As far as I know FB:Admins and FB:App_id is for if you have an entity on Facebook like page or app.
    But I do not have such.
    I just want to have a preview in a facebook post. What you suggest is that every website on the web has a FB:Admins and FB:App_id. I doubt it.
    While I rarely find websites or links that do not generate preview on facebook post.

    As I wrote earlier
    http://services.bg/uslugi/domashni-u...-services.html link is generating preview.
    http://services.bg/ is not generating preview.
    So this has nothing to do with FB:Admins and FB:App_id
    It is clearly a bug.

  5. #5
    Guru
    Join Date
    Jan 2013
    Location
    Australia
    Posts
    1,438
    I have also noted problems with now passing pictures over the last week or so, I ran your test option and found the following errors, although I do have admin and keys entered in to my plugin. You can see what the error is but I d not know how or why or how to fix it ?

    there are add times it will work but many times, the image is not available or shows?

    you can see the preview result shows no picture, this has only just started to happen and the error code ? I have no idea what it is even?

    Object at URL 'https://www.mysite.com/home-and-garden/kitchenalia/s-a-railways-pewter-tankard-355.html' of type 'product' is invalid because the given value '117848488233832' for property 'fb:admins' could not be parsed as type 'fbid'.
    Attachment 2453


    Attachment 2454


    EDit - as below mine has started working again ? odd
    Last edited by Pete Young; July 6, 2017 at 10:14 AM.

  6. #6
    Oddly enough, now it is half working!

    Root URL working, but it didnt work.
    Screen Shot 2017-07-06 at 11.58.19.jpg

    Default redirect to default region not working, but path to img is present. I check it first time.
    Screen Shot 2017-07-06 at 12.01.06.jpg

  7. #7
    Hello Stefan,


    1. I've told about fd:admins and fb:app_id data, because the facebook mark it as important parameters. You must create a app, but you can to don't use it.
    If website doesn't have this data, your website will have problems with parsings other data.


    2. Facebook must update own cache to fetch new images from each url. You can use object debug tool for it to get a new info.
    Thank you, Curtis.
    @Flynax Company

+ Reply to Thread