+ Reply to Thread
Results 1 to 2 of 2

Thread: [4.4.0 Installation] Syntax error in .../install/index.php on line 145

  1. #1

    Exclamation [4.4.0 Installation] Syntax error in .../install/index.php on line 145

    I got the following syntax error when I first open the site for installation: "Parse error: syntax error, unexpected ':' in .../install/index.php on line 145"

    I fixed it by changing "return $error ?: true;" to "return $error ? false : true;" in .../install/index.php on line 145. I got the Installation Wizard after doing this fix.

    Please look into it and confirm what I have done is correct and also update your files in downloads.

    Regards,
    Paulson

  2. #2
    Flynax developer John's Avatar
    Join Date
    Oct 2009
    Posts
    575
    Hello Paulson,
    You did it almost right, the line: "return $error ?: true;" is shorthand ternary operator which doesn't support
    by php less then 5.3. We already fixed this issue in the working version of the software and next update will have
    this issue fixed. Here the fixed code line:

    PHP Code:
    Only registered members can view the code
    John

+ Reply to Thread