PDA

View Full Version : Wildcard subdomian - page not found problem



Nizam Karim
July 7, 2017, 04:55 PM
Trying to set up Wildcard subdomain

1) Hosting /w Linode
DNS Manager
Hostname IP Address
added "A" record
*.Domain IP num

2) Using VestaCP using apache 2.215 only ( no nginx frontend)
DNS Zone file
/home/$user/conf/dns/$domain.db
added
* 14400 IN A Domain IP

3) Server Alias in apache configuration file
added
<VirtualHost *:80>
DocumentRoot /home/www/domain.com/public_html
ServerName domain.com
ServerAlias *.domain. com
</VirtualHost>

Restarted Apache

4) Flynax Admin
admin
Geo Filter - Location on subdomains = enable

However when I click on Country getting: ERROR 404: Requested page not found.

Am I missing anything here?

BTW
Forgot to mention before Flynax install /w (1) to (3) above wildcard was working i.e.
dog.domain.com
cat.domain.com
usa.domain.com
all of the above was working - no errors

SOLVED
I forgot, VestaCP also requires a CNAME record ...Arrr stupid me
After Adding it , rebooting server and clearing Flynax cache
It worked !

Sam Gill
July 10, 2018, 01:27 AM
I did all the above and failed to make it work it on Cent os7 Cpanel, is there any special setting that need to be addressed to on CentOS7?

Viktor
July 10, 2018, 03:36 AM
Hello Sam,

If you use Cpanel you need to create wildcard domain only and all subdomains will work.

Sam Gill
July 10, 2018, 11:07 AM
Dear Viktor

I Created wildcard domain successfully, Then changed Listing_type setting in admin, restarted apache

Tried after an hour - Did not work

Then created record in Zone Editor pointing to same IP, restarted apache

still did not work

Sam Gill
July 16, 2018, 06:21 AM
I am still facing problem, Have created a ticket also, Please help

Sam Gill
July 18, 2018, 11:43 AM
Wildcard domain has worked, it was because of Auto SSL was not providing SSL certificate for subdomains.

Somehow when Subdomain is switched on from FlynaxAdminPanel - buyers can not send message to sellers and message sending screen is stuck at loading

now I have given up on wildcard and have moved on,2909

Viktor
July 19, 2018, 03:14 AM
I have checked it on your side and all working properly for me. I have answered you in ticket and send video too.