PDA

View Full Version : Version Upgrade



Mike
April 25, 2016, 12:41 PM
Hi there,

Even though you have the ability to update your site yourself using patches provided by Flynax, updating is not an easy task because in case of a failure you might lose or break your site, and if you're not sure you can update your site without any problems we recommend asking Flynax to help with updating.

NOTE: we also recommend reading through all new features in an update to make sure you really need them. If you have a heavily customized site we advise against updating your site because you might lose more time and money on updating than on supporting your site.

If you made up your mind to update the site yourself then please follow every point of the guide below:

IMPORTANT! Make a full back up of your site and database before updating so you could quickly and easily restore your site in case of a failure. We don't assume any responsibility for updating issues arising from poor updating procedures.

1. Go to www.flynax.com site and log in to your Customer Area.
2. Go to Download page and click on Patches tab.
3. Select a patch and click the Download link.
Note: A patch for the Escort Script is marked with Escort_ prefix.
Note: A patch for the All-In-One Script is marked with Classifieds_ prefix.
4. After downloading the patch archive to your MAC/PC make sure it looks like FLXXXXXXXXXX_vX.X.X_to_vX.X.X.zip or with Escort prefix if you're updating an escort site. The patch is made up of files and SQL file for updating the database (sql_update.sql).
5. Go to the Admin Panel > Database and click the "Import" button (top left corner) > select the SQL file from the patch main folder: sql_update.sql, and click the GO button.
You also can apply the SQL update through a database manager like phpmyadmin by replacing {sql_prefix} with the correct SQL prefix used in your database.
6. Unzip all files and copy each file to a corresponding directory on your server. Remember! You should copy files of your template only from /templates/ directory in the patch.
You can upload files to your site using an FTP manager or cPanel File Manager; whatever you choose please make sure that files from patch will overwrite existing site files. All changes made to these files will be lost after rewriting them with patch files.

NOTE: If your site was customized you'll have to compare and merge new files with custom files (located on server) before uploading new files to the server. The same procedures must be applied to customized template files.

NOTE: If your admin directory is not 'admin' please rename the admin directory in the patch to your custom name before uploading the patch.
NOTE: If your language code is not 'en' please open sql_update.sql and replace 'en' with the proper language code.
NOTE: If you have more than one language you will have to compare languages and copy newly added phrases to other languages after applying the patch.
NOTE: If you want to update your site to the latest version and your current version is a few updates behind, then you'll need to apply every update consequently from older to newer version until you update your site to the latest version, for instance: from 4.1 to 4.2 then from 4.2 to 4.3 etc.


Special Note for upgrading from 4.5.1 to 4.5.2: You have to do the following change when updating your site to make it work (you can also find it in README FILE)
Open the README file and find the code that looks like:
define('RL_SETUP', 'ARANDOMSETOFNUMBERSANDCHARACTERS=');
Paste it to the includes/config.inc.php to the bottom of the file.


Updating is over! You can open your site and test its functionality.
If you get any problems after or during updating feel free to contact us.

Pete Young
April 25, 2016, 01:31 PM
Thank you Mike for the guide, It Would be nice to see a you tube video of this process, also what procedure would you take if you wanted to just do a complete fresh install and start from scratch ?

thanks
Pete

Heiko Senska
April 25, 2016, 05:37 PM
What a patch I see nothing with me

Wei Hong
April 26, 2016, 04:26 AM
Hi Mike, I have successfully updated to v4.5, but I found some menu is missing. For example: the membership plan under monetarization in admincp? I checked on the demo is it there but not on my site. How do I fix it?

Mike
April 26, 2016, 05:44 AM
Thank you Mike for the guide, It Would be nice to see a you tube video of this process, also what procedure would you take if you wanted to just do a complete fresh install and start from scratch ?

thanks
Pete

OK, we will record a video soon, however process may be different on different servers.

Mike
April 26, 2016, 05:45 AM
What a patch I see nothing with me

Patches are in your flynax.com account area -> downloads -> patches.

Mike
April 26, 2016, 05:50 AM
Hi Mike, I have successfully updated to v4.5, but I found some menu is missing. For example: the membership plan under monetarization in admincp? I checked on the demo is it there but not on my site. How do I fix it?

Please note patch contains phrases only for English language. If you have more than one language you have to Compare Languages in Admin Panel>Languages; It will copy newly added phrases to other languages.
Maybe this is your issue.

If your language code is not 'en' (sometimes after translation code still 'en' but languages is different) you have to replace 'en' with the right language code before applying patch, or after applying patch in the database->lang_keys table.

Wei Hong
April 26, 2016, 08:30 AM
Please note patch contains phrases only for English language. If you have more than one language you have to Compare Languages in Admin Panel>Languages; It will copy newly added phrases to other languages.
Maybe this is your issue.

If your language code is not 'en' (sometimes after translation code still 'en' but languages is different) you have to replace 'en' with the right language code before applying patch, or after applying patch in the database->lang_keys table.

Oh I have English language, but the code is 'us' not 'en', is that the reason why I have blank phrase? So you recommend me to redownload the sql patch and change the 'en' to 'us' then import it again? And similarly to another language? But how about the options membership plan missing from monetization section? Is it because of the language key as well?
Thanks for enlightening me

Mike
April 26, 2016, 11:21 AM
Oh I have English language, but the code is 'us' not 'en', is that the reason why I have blank phrase? So you recommend me to redownload the sql patch and change the 'en' to 'us' then import it again? And similarly to another language? But how about the options membership plan missing from monetization section? Is it because of the language key as well?
Thanks for enlightening me

Yes you have to download patch and replace lang code with us, but import only language related data.

Please don't run other sql queries, only those that related to lang_keys table.

Mike
April 26, 2016, 11:24 AM
For those who have sql problem during upgrading to 4.5 version


Failed to run the SQL query.Duplicate column name 'Plan_type'

you can use attached file to complete database patching.

Pascual Bernardo jr
April 27, 2016, 01:45 AM
DONE->
5. Go to the Admin Panel > Database and click the "Import" button (top left corner) > select the SQL file from the patch main folder: sql_update.sql, and click the GO button.


6. after overwrite all existing site files (even sql_update.sql file) my website shows MYSQL ERROR.

Viktor
April 27, 2016, 04:03 AM
Hello Pascual,

Would you please send me ftp access. I will check it or open file: ftp://tmp>>errorLog>>errors.txt and see last errors. If you know mysql of course :) if not send ftp to my PM.

Pascual Bernardo jr
August 1, 2016, 04:42 PM
Thanks for the info. I hope the flynax team write more instruction like this. I bought a script March 2016 (5 months ago) but until now my website is not running properly. >_<

Vitalii Nikitchuk
October 1, 2016, 11:30 AM
What to do with the folder - install? When updating

Curtis
October 2, 2016, 03:39 PM
What to do with the folder - install? When updating

You can rename or remove it.

Abdul Basit
January 13, 2017, 06:39 PM
any body can help me for up gradation of software 4.5.1 to 4.5.2 ???

Evren
January 26, 2017, 08:00 PM
I am using boats script. Which patch file should I download ?
Update patch from v4.5.1 to v4.5.2 or Update patch from v4.5.1 to v4.5.2 (Classifieds) ?

Curtis
January 27, 2017, 05:57 AM
I am using boats script. Which patch file should I download ?
Update patch from v4.5.1 to v4.5.2 or Update patch from v4.5.1 to v4.5.2 (Classifieds) ?

You need use the general patch, because the "Classifieds" patch must be used for All-In-One only.

Shahzad Ahmed
August 9, 2017, 11:26 AM
Hi as am new in wordpress kindly let me know where from i can get Installation Wizard...?

Viktor
August 10, 2017, 03:45 AM
Hello Shahzad,

Go to Flynax site login with your account and find in your download area: Patches. Find your patch and download it.

Yassine Azhari
November 22, 2017, 05:57 PM
Erreur:

Viktor
November 23, 2017, 08:32 AM
Would you please write your error in text file and attache here or show error on screenshot.

Vitas Loda
November 29, 2017, 01:05 PM
This update tutorial valid 4.5.2 to 4.6v ?

Viktor
November 29, 2017, 01:39 PM
Yes tutorial the same. You can learn it and please be careful and don't forget about backup files.

Francisco Ferreira da rocha
December 20, 2017, 03:58 PM
Dear, when upgrading from 4.6 to 4.6.1 should the Install folder also be sent to the server?

Viktor
December 21, 2017, 04:14 AM
Hello Francisco,

If you plan to reinstall your software in future you can change install folder too.

Francisco Ferreira da rocha
December 21, 2017, 05:07 PM
Hello Viktor, I would like to know if during the update it is necessary to send to the server also the install folder, along with all the other files of patche 4.6.1 that will be replaced in the server, because also sending the install folder will be executed the reinstallation.
Is this the same for updating my version 4.6 to 4.6.1?
To upgrade from 4.6 to 4.6.1 do I really need to send the install folder to the server?

Rudi
December 22, 2017, 05:02 AM
Hello Francisco,

The sql patch you can apply via admin panel > Common > Database

but the new script files should be uploaded via ftp server (or cpanel)
you can just insert files from patch folder into corresponding script directories replacing the old files
or
install the script from scratch using the script package 4.6.1

Halit Kincal
December 27, 2017, 10:09 PM
Is it possible to upgrade from 4.5.2 to 4.61 ? or ı have to upgrade first from 4.5.2 to 4.6 then 4.6-->4.61 ?

Rudi
December 28, 2017, 02:49 AM
Is it possible to upgrade from 4.5.2 to 4.61 ? or ı have to upgrade first from 4.5.2 to 4.6 then 4.6-->4.61 ?

Hello,

you should upgrade your script consistently from 4.5.2 to 4.6 and from 4.6 to 4.61

Nikolai Razouvaev
January 24, 2018, 09:36 PM
Getting this SQL error on updating from 4.5.2 to 4.6

Error: Failed to run the SQL query.Duplicate column name \'Session_hash\'
Error: Failed to run the SQL query.Table \'jadoowor_wide.{db_prefix}listing_photos\' doesn\'t exist
Error: Failed to run the SQL query.Table \'jadoowor_wide.{db_prefix}payment_gateways\' doesn\'t exist
Error: Failed to run the SQL query.Table \'jadoowor_wide.{db_prefix}payment_gateways\' doesn\'t exist
Error: Failed to run the SQL query.Table \'jadoowor_wide.{db_prefix}blocks\' doesn\'t exist
The MySQL dump has corrupt queries; importing the new language has failed.

Viktor
January 25, 2018, 02:35 AM
Hello Nikolai,

Open sql file in update folder and replace: {db_prefix} to fl_ or other your prefix.

Anass Habrah
January 18, 2019, 10:47 PM
when try to import sql for upgrade showing me this:

Failed to run the SQL query.Duplicate column name 'Cron'
Failed to run the SQL query.Table 'souqsham.{db_prefix}accounts' doesn't exist
Failed to run the SQL query.Table 'souqsham.{db_prefix}accounts' doesn't exist
Failed to run the SQL query.Table 'souqsham.{db_prefix}account_fields' doesn't exist
Failed to run the SQL query.Table 'souqsham.{db_prefix}listing_packages' doesn't exist
The MySQL dump has corrupt queries; importing the new language has failed

Anass Habrah
January 18, 2019, 10:54 PM
and after replace: {db_prefix} to fl_ or other your prefix.
showed me this:
Failed to run the SQL query.Duplicate column name 'Cron'
Failed to run the SQL query.Duplicate column name 'Cron_notified'
Failed to run the SQL query.Duplicate column name 'Last_step'
Failed to run the SQL query.Duplicate column name 'Count_used'
Failed to run the SQL query.Duplicate column name 'Thumbnail_x2'
The MySQL dump has corrupt queries; importing the new language has failed

Pete Young
April 15, 2019, 11:36 PM
Thank you Mike for the guide, It Would be nice to see a you tube video of this process, also what procedure would you take if you wanted to just do a complete fresh install and start from scratch ?

thanks
Pete

Moving on 3 years and I do not think there has been a video made to date ? and in some ways that does not matter in the scheme of things, but due to a recent experience with updates, feel this area could do with a tidy up.

Having recently applied to have my site upgraded from 4.7.0 to 4.7.1 I submitted a request for an invoice to pay to have this work done ( as after 3 years not real sure on doing this myself given the basic instructions and do not wish to screw it up ) and also I do not mind paying Flynax some money to help the wheels go around.

It was with upgrade that not only did I need to pay for the upgrade, but now ( for the first time ever since being with Flynax ) I now need to pay to have my template also upgraded to 4.7.1.

News to me of sorts, In that I have never had this happen before. In a way I am not to fussed by this either, but I see a big gap in communication of sorts. Flynax issues a blog post listing all of the great fixes in the new version, so why not at the bottom of that blog post put a NB in bold that states

PLEASE NOTE: that upgrading to V 4.7.1 Will Require you to upgrade to the new 4.7.1 Template and Any Work you have Done on Your Existing Template Will Be Lost.

I am sure like most if not all people here that we do work on our templates and to have this come out of the blue after many weeks / months of modifying your template is a kicker to find out after you have gone through the Upgrade process.

Now in this case I am being offered to upgrade my template to 4.7.1 ? which as above I have never heard of before, but now the question begs, if there is such a thing as having to upgrade the template as well, then why then is there also not a upgrade / patch for that.

I suppose in summary lets get real clear on the information and what is required with updates, and yes if possible clear instructions / a video, and lastly if Template upgrades are also required when we upgrade, supply those patches and instructions as well all up front and so that people do not have surprises and or confusion hiding in the shadows of the Flynax corridors of upgrades.

For me I will just keep paying for the upgrades, and even with that the process and or what is required for upgrades needs to be very clear for everybody.

Just an Edit to this.

People also need to keep in mind that plugins are also not updated in most cases when a new script version is released, so in order to be successful with any script upgrade, you now would need to ensure you have a template upgrade to match or be prepared to start over with that and ensure all plugins that you have running, have also been upgraded Before you update to the new script version or you are going to be flapping around like a bird with no wings.
.