View Full Version : mod_rewire error

Chris Brewer
January 19, 2016, 07:10 PM
I have mod_rewrite enabled on my server, and turned on in Flynax, yet URLs are not rewritten and 404 errors result.

Other software (Concrete5) using mod_rewrite works without issue on the same server.

I have posted a support ticket but hope for quicker resolution here, as support is very slow from Flynax.

January 20, 2016, 11:33 AM
Hello Chris,

I solved problem with mod_rewrite. It happened because you site in subdomain. I have added 1 line in general htaccess file and now site working properly.

Chris Brewer
January 20, 2016, 08:14 PM
Thanks for your help Viktor. For anyone interested, Viktor's solution was to add the entry to .htaccess under the #wilcard request block, for the subdomain where we're hosting the site, which is "buy":

RewriteCond %{HTTP_HOST} !^buy\. [NC]

Tinashe Nyabako
August 11, 2016, 07:19 AM
I am having the same problem. This solution didn't work for me. mod_rewrite is active from my webhost but when I turn on mod_rewrite in flynax backend I get 404 errors on all pages. Facebook login works once rewrite is on but I get another 404 error after redirect from Facebook.

Is there any other possible solution?

Tinashe Nyabako
August 17, 2016, 05:50 AM
Solved the problem by adding "RewriteBase /subdir2/" in .htaccess file.