View Full Version : Can't add a picture

Sean Mckellar
July 15, 2015, 04:48 AM
I am currently experiencing a problem with a new flynax installation - pictures can't be added to a new listing. See screenshots for clarification:

1. The listing information has been filled out and we arrive at the "Add a picture" page

2. The button is clicked and I select a photo to upload (I have tried many sizes, from very large to very small file size photos) and then click "Open"

3. We return to the "Add a picture" page and nothing happens.

Have you come across this before and if so is it an easy fix?
I thought I may have customised something which caused the error, but I installed a new flynax installation in a different directory and it experienced the same problem.

Note: I have also tried disabling the "Uploading pictures in auto mode", but this also doesn't work. The "Upload" button remains greyed out, even after selecting an image.

I look forward to hearing back.
Thank you.

Sean Mckellar
July 15, 2015, 08:17 AM
Actually I believe this was caused by some of my template modifications - please disregard.

July 15, 2015, 08:29 AM
Hello Sean,

Would you please send ftp access to my PM and I will check and solve it ASAP.

Sean Mckellar
July 16, 2015, 12:59 AM
Hi Viktor - I have traced the problem back to jquery.
I have successfully integrated a custom WordPress header and footer into the flynax template, but the WordPress header calls "jquery.js?ver=1.11.2" which to me seems to be conflicting with the jquery which flynax loads.
If I remove the jquery load code from the custom WordPress header template, the flynax 'Add a picture' suddenly worked fine. But then I lose some functionality with WordPress...

Sean Mckellar
July 16, 2015, 01:32 AM
I fixed this by adding "<script>var $ = jQuery.noConflict();</script>" at the base of the wordpress header, it all seems to be good now :)