View Full Version : Request exceeded the limit of 10 internal redirects

March 19, 2014, 10:40 AM
Hello everyone,
I'm new here, and trying to set up flynax.

I'm trying to install the script on a subdomain sub.domain.com
I've changed the RewriteBase on .htaccess already to:

RewriteBase /ads/

so for a start let me know if this is correct.

The problem now is that I get an Internal Server Error (500) and on the error log I see:

Request exceeded the limit of 10 internal redirects due to probable configuration error.

Which pretty much I can understand it mean that you there are many .htaccess files with different redirects which may not work together, or something of the sort.

Could someone help me on solving this?
the script is out of the box, no modifications as I've just got the license!

Thank you in advance!

March 20, 2014, 08:28 AM
Hello Spyros,

YOu shouldn't change .htaccess file because you installing script in subdomain. If you want to install in subdirectory you should change .htaccess file.
Return htaccess file back. and if you want I can check it. Send cpanel access details to my PM and I will try to solve it.

March 20, 2014, 09:08 AM
Thank you for this Victor,
I changed the rewrite line back to default and as John told me on the support ticket I've opened for the issue, I changed this line:

RewriteCond %{HTTP_HOST} !^www\.|m\. [NC]

to this line:

RewriteCond %{HTTP_HOST} !^www\.|m\.|ads\. [NC]

but it still doesn't work! No Error 500 this time, but the site doesn't load properly, and I get this error now

Error: the xajax Javascript component could not be included. Perhaps the URL is incorrect?

so still working on it! Could you please have a look?

March 20, 2014, 11:58 AM
Hello Spyros,

Please provide me cpanel access details or ftp access and I will check and solve it. I should check some things :)

March 20, 2014, 01:04 PM
I've sent you a PM Viktor

March 21, 2014, 03:24 AM
Hello Spyros Angelopoulos,

May be I don't understand something but your site working very well for me.
Would you please explain me better what is wrong??!!!

March 21, 2014, 09:16 AM
Viktor, I sent you details and screenshots via PM showing that the site doesn't work!
Can you please help me? Thank you! The ticket support is very slow, they respond once a day!
With that pace, the 3 months support will be enough for 2 problems or so...

March 21, 2014, 09:38 AM
I hope that when the problems are solved my site will look better than this... :)

March 21, 2014, 12:18 PM
I reinstalled it and the problem persists

March 22, 2014, 10:21 AM
The problem persists, and the support replies once per day without doing anything...
an ongoing ticket of four days without any substantial support!

March 22, 2014, 12:11 PM
I think this is related and the developers should have a look and fix the problem:


There was a bug in JS minifier with missing semicolons which caused this issue.
I fixed it in revision 8 and I'll release a new version ASAP. until then you can get changed file from here:


March 23, 2014, 01:47 AM
Any ideas? Also the mobile version doesn't work

March 23, 2014, 11:19 AM
I'm on the fifth day of this problem, haven't heard from the support for two days and the problem still persists...

March 24, 2014, 03:30 AM
Hello Spyros,

I have answered you in PM and would you please send me ticket ID. I will check your ticket.

March 24, 2014, 08:03 AM
I've replied to you Viktor

March 26, 2014, 08:57 PM
So, I found the problem myself and listing it here for you in case someone else faces the same problem in the future! The problem was the name of the subdomain "ads"...
The adblock plugin was seeing it as an ad site and was blocking it all together (the java files basically)! Which is sad to see one's not able to have a short subdomain because of that!
But anyway, I've chosen a different subdomain and the site is up and running now!