View Full Version : Quick Search Bug on Home Page = BUG?

Steffen Buschkemper
December 8, 2013, 01:01 AM
Hi Guys,

i have a problem in Flynax General Classifieds v 4.2 with general_simple_green template.

I can not see any fields in Search Box (home_search_form).
Next bug is on Advanced Search Page - the Link "Quick Search" bring me to listings.html and not back to search.html.

A refresh for form fields i have already made...
Where is the problem?


Steffen Buschkemper
December 10, 2013, 11:16 AM
Hi @ All,

Can someone check if the problem also exists with him in the 4.2 version?

I have now tried everything, but the search form fields are simply not displayed.


December 10, 2013, 11:50 AM
Hi Steffen,

Its hard to say what is the problem just from your explanation.. can you please pm me details to check or submit a ticket.
Is it clean 4.2 ?

Steffen Buschkemper
December 12, 2013, 05:12 AM
Hi Mike,

It is clean to 98%. Well 80% ;)
I will pm you details if i have installed the script online.


Wei Hong
January 14, 2014, 07:35 AM
My quicksearch form disappeared as I reinstalled and rebuild my site using the newest version 4.2, any idea how to fix this?
My search form is well build, not blank

Steffen Buschkemper
January 14, 2014, 08:20 AM
Hello Wei Hong,

this is a problem from version 4.2.
The flynax team has this problem - until now not been checked and corrected.
Would be good if flynax checked its final version - before they published into the download area.

But there are always the supposed server, host problems or customizations. :rolleyes:
I also have not found a solution at this time. Sry

I have also installed a clean 4.2 version and the problem is present.


Wei Hong
January 14, 2014, 08:24 AM
Oh no. For real?
There should be a way to fix it right?
Because that feature is very important to me. Should I go back to 4.1?

Steffen Buschkemper
January 14, 2014, 08:29 AM
The problem could the team already solve, if they would try it once in their final.
But there are even more bugs. Not only this...

Wei Hong
January 14, 2014, 08:41 AM
I installed a completely clean 4.2 version, I then deleted all of the categories that I don't need and created mine. The problem pop-up. This is a really important feature so I hope flynax could fix it or I would have no choice but to go back to 4.1 . Sad face. And your statements of "There are even more bugs" stabbed me. Is there any thread of 4.2 bugs report that I should be aware of?
And thank you so much Steffen for always staying with us

Steffen Buschkemper
January 14, 2014, 08:47 AM
Hello Wei Hong,

Bugs can be published in this Bug Reports area for every versions.
But i lost interest in it to write bugs there, as this area in my opinion is absolutely useless.
The team ignores most messages there.


Wei Hong
January 14, 2014, 08:51 AM
You just broke my will to dig into finding a way to fix it Steffen.
Have you tried creating a ticket about this bug and if you did what did they tell you and when was it? Hopefully they 've been working on this and fixed it. This should be easy for them right? It's nothing big, the same old quick search block on main page.

Wei Hong
January 14, 2014, 09:04 AM
Either way. I would like to hear from Flynax Dev if they can fix this. So please flynax, let me know. If it can't be fixed. I will then need to go back to 4.1 and start all over again. Because this feature is the basic for all classified scripts and for that reason it is very important to me.

Steffen Buschkemper
January 14, 2014, 09:08 AM
Hello Wei Hong,

A ticket i have not created yet, because i am currently working local on the script.
In addition, i find a ticket in this case inappropriate, since it is a bug, that have seemingly all 4.2 versions.
I have it published here and would like for all to see here a solution for that.

...statements of "There are even more bugs"...

I also suspect that therefore the demo pages from flynax are not v 4.2 until today.

Best Regards

Wei Hong
January 14, 2014, 07:24 PM
I have created a ticket last night and pray for its solution.
Honestly, I would really appreciate if any of Flynax officers could give me an official info about this bug. So I can continue working on my project. Would be great if 4.2 work out, or if I had to, I would uninstall 4.2 and reinstall 4.1

January 15, 2014, 06:24 AM
As you may notice there is no teaser as in modern templates for search forms, when you first time set template it's supposed to add a box with search form inside. Seems problem on this step.

I will try to reproduce it on my installations and i will get back to you with solution if i will be able to reproduce.

January 15, 2014, 06:57 AM
I have looked into it, but i didn't find any problems. As supposed after switching to green template it created correct search box

try to replace file search_block.tpl with file from attached zip (template/tpl/blocks)

maybe it will solve your problem, if so it's already fixed i 4.2 but for some reason your installation don't have correct file.

Steffen Buschkemper
January 15, 2014, 07:40 AM
Good morning Mike,

As supposed after switching to green template it created correct search box

I know, this is controlled by the settings.tpl.php.

My code of search_block.tpl looks like this:

<!-- search form block -->

{assign var='spage_key' value=$listing_types[$form.listing_type].Page_key}
<form method="{$listing_types[$form.listing_type].Submit_method}" action="{$rlBase}{if $config.mod_rewrite}{$pages.$spage_key}/{$search_results_url}.html{else}?page={$pages.$spa ge_key}&amp;{$search_results_url}{/if}">
<input type="hidden" name="form" value="{$form_key}" />

{foreach from=$hidden_fields item='hField_val' key='hField_key'}
<input type="hidden" name="f[{$hField_key}]" value="{$hField_val}" />

{foreach from=$form item='group'}
{include file='blocks'|cat:$smarty.const.RL_DS|cat:'fields_ refine.tpl' fields=$group.Fields postfix=$block.Key}

<input style="margin: 10px 0 0 0;" class="button" type="submit" name="search" value="{$lang.search}" />

{if $use_photos}<input id="photos_{$form_key}" type="checkbox" name="f[with_photo]" value="true" /> <label for="photos_{$form_key}" class="fLable">{$lang.with_photos_only}</label>{/if}
<!-- search form block -->

actually identical except for the first line smarty code, form action and method.
I will check your file later and will post here the result.

One more question, why do i get at the backend for flynax blog feed and plugin changelog the following message?
The same also in plugins tab -> Therefore, no possibility to update and install plugins.

Unable to reach Flynax Server

In the 4.1 version no problems in 4.2 comes this message.
Server settings are the same. Nothing changed.
Problem both locally and online.


January 16, 2014, 08:48 AM
It may result from additional checking for resourse avialability which in some cases fails and result to problem.

try to open classes/reefless.class.php find code and remove and comment

function getPageContent($url)
$parsed_url = parse_url($url);
if ( !$url || !$parsed_url['host'] || (function_exists("checkdnsrr") && !checkdnsrr($parsed_url['host'], "A")) )
return false;

it should fix this problem